Project

General

Profile

Error #108

Missing c-type extension or missing c-type methods

Added by Manuela 5 months ago. Updated 5 months ago.

Status:
Done
Priority:
Hoch
Assignee:
Target version:
Start date:
2022-04-24
Due date:
2022-04-27
% Done:

100%

Estimated time:

Description

There are two solutions available.
  1. The first and safest method on Linux:
    If your server runs on Linux, the problem is solved with a few mouse clicks or terminal entries: Just ask your hosting provider to install the ctype extension. The extension is usually included in the PHP package recommended by the PHP group as the default.
  2. With Windows servers it is much more complicated, since the extension has to be compiled into PHP. A userland solution is being worked on here.

History

#1 Updated by Dietmar 5 months ago

  • % Done changed from 80 to 90

#2 Updated by Dietmar 5 months ago

Like the description told us, the issue in your case is that ctype_alpha does not exist in your system. You need to make sure that the ctype extension is loaded (it is an extension that is enabled by default when compiling PHP.

Alternatively, if you cannot enable the extension, with our patch we install the symfony/polyfill-ctype composer package which provides a userland implementation of the ctype functions (but be aware that they are slower than using the extension, so if you care about performance, you should definitely work on enabling the extension instead).

#3 Updated by Dietmar 5 months ago

Please download test the newest Patch 2.13.1.112 https://addon.websitebaker.org/pages/en/browse-add-ons.php?download=04D6D0F4 and inform us the result

#4 Updated by Dietmar 5 months ago

  • Due date set to 2022-04-27
  • Status changed from In Progress to Done
  • % Done changed from 90 to 100

Also available in: Atom PDF